You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close
Home > WipeDrive Query Tool > How to Update the WipeDrive Schema Version
How to Update the WipeDrive Schema Version
print icon

When there has been a WipeDrive release, generally there can be additions or modifications made to the database tables that require the schema version to be updated. If running a new version of WipeDrive with an older database, you will receive an error message when WipeDrive attempts to log that looks something like this: 

 

This means that your database needs to be updated to the newest version. In order to do this, you will need to download and run the latest WhiteCanyon database tools. Links to those downloads can be found here:

WhiteCanyon SQL Database Initializer

WhiteCanyon SQL Query Tool

 

The tool that needs to be run in order to update to the latest schema version is the database initializer.

Once the initializer has been downloaded and installed, when ran it will prompt you for your database user credentials.

 

After all your credentials have been entered, simply press 'Populate Database' and the tool will make all the necessary updates to the database for you. Once this has been completed, WipeDrive should now be able to log once again.

 

FAQ

Does updating the schema version erase any of my existing records?

No, all existing data is left as is and is not modified during the schema update process. Updating to a higher schema version is completely safe!

 

Can I use an older version of WipeDrive if my database has an updated schema version?

Yes, older versions of WipeDrive will still log to a newer database just fine since there is a place for all of the data to be stored. The only problem is the other way around where tables for the new data may not exist yet in an older database.

 

Do I need to update my query tool too?

Yes, when updating your database to the most recent schema version it is important to also update your query too. This is because various features of the query tool need to stay up to date with the schema version so that various functions can continue to work. Don't worry though, new versions of the query tool can still interact with your old records!

Feedback
0 out of 3 found this helpful

scroll to top icon