SecureClean System Requirements

SecureClean is compatible with Windows XP, Vista, and 7.  Currently, SecureClean is not guaranteed to work with Windows 8 or higher machines.

  • 31
  • 30-Oct-2017
  • 354 Views